Washi room edit · Quiet free shipping over $75 · Soft restocks

HP EliteBook 840 G11 Intel Core Ultra 7 155H Laptop 35.6 cm (14") WUXGA 32 GB DDR5-SDRAM 512 GB SSD Wi-Fi 6E (802.11ax) Windows 11 Pro AI PC Silver Display resolution___2256 x 1504 pixels 1 kg Sustainability European Product

4.8
USD867.87 USD912.87

Pay in 4 interest-free payments of $216.97 Learn more

SKU: 29534064859

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Oct 1 - Oct 6

Description

HP EliteBook 840 G11 Intel Core Ultra 7 155H Laptop 35.6 cm (14") WUXGA 32 GB DDR5 SDRAM 512 GB SSD Wi Fi 6E (802.11ax) Windows 11 Pro AI PC Silver Display resolution___2256 x 1504 pixels 1 kg Sustainability European Product 1 kg Sustainability European Product Registry for Energy Labelling (EPREL) code 342403 Sustainability certificates EPEAT Gold 775Gbps WiFi security WPA PSK WPA2 PSK WPS PBC(Push Button Config) & station PIN IP protocols RFC 791 (IP) RFC 793 (TCP) RFC 768 (UDP) RFC 792 (ICMP) RFC 826 (ARP) RFC 1661 (PPP) RFC 1332 (IPCP) RFC 1334 (PAP) RFC 1994 (CHAP) NAT NAPT RFC 3022 Browser IE Firefox Safari Opera Chrome ZTE Link Andraiod and iOS APP to management the device

You may also like

recommand products